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DT - How to - 01 - Decision Tables Overview
[TOC]

Overview
A Decision Table represents a collection of related business rules with condition rows, rules, and actions presented in a tabular form that is easy to
understand. Business users can review cells and their values at a glance and can use Decision Table rule building features by clicking icons and
selecting values in the Decisions Table builder.

Decision Tables allow us to create and use business rules in an easy to understand format that provides an alternative to the IF/THEN rule format. The
spreadsheet nature of a Decision Table ensures that business analysts, functional consultants, etc. who are familiar with spreadsheets find them easy
to construct, read and modify.

The compressed nature of business rules presented in the form of decision table make them fast to understand, clean and readable. The simple
visualization of a compact and structured table format aims to mimic real world business problems with many tables breaking down complex
problems into simple steps.

Example of a Simple Decision Table to Calculate a Contacts eligibility for a Credit Card

Why use Decision Tables? 
Automating business processes using software such as Dynamics CRM has become a key return on investment (ROI) factor when conducting benefit
analysis for new software deployments.    

Businesses today are trying to make use of all their resources so this means not relying solely of software developers for implementing business rules.
When software can empower business analysts/functional consultants to work together with software developers this leads to CRM projects being
delivered on time, to specification and within budget. We believe that Decision Tables enables a synergy between business analysts, functional
consultants and software developers when delivering projects.

In addition, many organisations are experiencing an increasing burden to make software systems more responsive to business changes, so allowing
trained business users to change business rules is becoming increasingly important.

What makes up a Decision Table?
Decision tables are rules composed of rows and columns. They are used to display in table form all possible situations that a business decision might
encounter, and to specify which action to take in each of these situations. A decision table expresses sets of related conditions and actions in a
spreadsheet like view. Each row is in effect a single rule in the table made up of many rules. Each column is the definition of a Condition or Action.

Decision tables are composed of rows and columns. As shown in the following table, each row corresponds to a single rule [4], with the columns
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defining the conditions [1] and actions [3] of the rules. The second row [2] of the table contains the column header, where we have the column names.

A condition is a test that must evaluate to true for the associated action to be executed. If a decision table rule uses multiple conditions, all conditions
for a row must evaluate to true for the action to execute. Condition tests might be looking to match the exact value of a fields value, or might be
comparing values against a greater than or less than value. In more complicated situations functions may be used for this comparison test so for
example using a function ‘StartsWith’ to check does the first 4 characters of an input value match a certain string.

To help understand the make-up of a Decision Table, consider a set of IF/THEN rules that determine if a Contact is eligible for a Gold or Platinum credit
card, and an equivalent Decision Table.

The IF/THEN rules follow:

if Contact.Category = {Preferred Customer} and Contact.Credit Limit > 2,000,000 then Contact.Credit Card Type = {Platinum}

if Contact.Category = {Standard Customer} and Contact.Credit Limit > 1,000,000 then Contact.Credit Card Type = {Gold}

Corresponding Decision Table

What happens when a Decision Table Executes?
When a Decision Table executes each row of the Decision Table is processed one by one. The Conditions are evaluated column by column from left-to-
right in an ‘AND’ or  ‘OR’  fashion depending on the configuration. Then any Action commands associated with a row (i.e. whose conditions evaluate to
true) are executed. 

Taking the decision table above,

For each row in the decision table, the Contact.Category column value is evaluated first followed by Contact.Credit Limit in an AND manner. If the
conditions both equate to True then Contact.Credit Card Type is set to Gold or Platinum.
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DT - How to - 02 - Create your first Decision Table
[TOC]

Overview
In this article we will demonstrate the basic steps involved in setting up a North52 Decision Table.

Set up the North52 Formula
Create a new North52 Formula record, to open the Formula Guide
Set Select Entity to be Account
Set Select Formula Type to be Save - Perform Action
Set Select Editor to be Decision Table
Click the Create button

This will open up the Decision Table editor canvas

From the Source tab, expand the Source & Target section
The Source Entity should be Account
Click on Annual Revenue within the Source Property field select it
Save the Formula
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What are Conditions?
Conditions are prerequisites for Actions.

What does that actually mean? When certain conditions are met, then the action will be triggered. For example, a condition might be that when the
Annual Revenue of an account is greater than $1,000,000 then the Credit Limit on that account should be set to $75,000.

To set a Condition you click on the blank yellow field (1) under Condition and then click on the Source (2) tab on the left-hand configuration pane and
then click on the field you want to set as your condition. 

In this instance we are going to use Annual Revenue (3)

Annual Revenue will now appear in bold text under Condition.
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Now that we have selected Annual Revenue to be our condition, we need to specify what the condition will be.

In cell A4 type >1000000 and in cell A5 type <1000000

This tells the Decision Table that we want to do 'Something' when the Annual Revenue is greater than $1,000,000 and to do something else when it it
less than $1,000,000.
 

What are Actions?  
Actions are the desired outcomes you want. In this example the Action is that we want to set the value of the Credit Limit field on the Account.

To do this, we click on the blank green cell (1) under Action and then click on the Source (2) tab on the configuration pane and then click Credit Limit (3)
in the list of source fields.
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Credit Limit should now appear in the Action green cell (B2).

For example, if the Annual Revenue is greater than $1,000,000 then the Credit Limit should be set to $75,000.
However, if the Annual Revenue is less than $1,000,000 then the Credit Limit should be set to $25,000.

Type 75000 in cell B4 and 25000 into cell B5.
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Finally save the formula and you have finished setting up your first Decision Table.
 

Testing the Decision Table
Open an Account record and set the Annual Revenue field to $500,000.

When you save the account record, the Decision Table will execute and update the Credit Limit field to $25,000.

Finally, change the Annual Revenue to $1,500,000, click Save and the Credit Limit will update to $75,000.
 

DT - How to - 02 - Create your first Decision Table - Page 9 of 98

https://www.north52.com/knowledgebase/basicDecisionTable8.png
https://www.north52.com/knowledgebase/DecisionTableSetAccountRevenue.png
https://www.north52.com/knowledgebase/DecisionTableSetAccountCreditlimit.png


DT - How to - 03 - Learn everything you need to know
about Decision Table Conditions
[TOC]

Overview
This article will detail everything you need to know about how to set Conditions in N52 Decision Tables.

It is assumed you already have some familiarity with Decision Tables or have at least read 'How to - Create your first Decision Table'

What are Conditions?
A condition is what triggers an action, it can be as simple as checking the value of a field or as complex as a multi-field, multiple function
lookup. Decision Tables give you the flexibility and the power to allow you to adapt your conditions to whatever you are trying to achieve.

By default when you open a Decision Table it shows you 1 Condition.

You can add additional conditions by right-clicking on the Decision Table editor and selecting Insert > Insert Condition from the contextual pop-up
menu.

After adding your required Condition columns you will need to populate them.

Condition Values
Before we continue - this is a quick overview of what information you can put in a Decision Table cell:

If the value is in single quotes then it is treated as a String value
If the value is in curly brackets {} then it is checked and treated as an OptionSet value
If the value is in curly brackets {} and not an OptionSetValue then it is treated as a parameter for an In() function  
If the value is a number then it is treated as a Number
If 2 number values are inside parentheses separated by a comma then they are treated as a between
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Note: Numerical comparison operators like >, <, >=, <= are all acceptable

When comparing between number ranges it is possible to use (( 100, 200 )) for example. This will be true if the number is >= 100 and <= 200. You can
use any combination of  ([ and ]) if you want to exclude the outer values. 
([ 100, 200 )) would be >100 and <= 200 etc.

Setting a simple Condition on a Source Entity field
You need to associate a field to the Condition column so that the Decision Table can use the value of that field to 'make decisions' according to the
rules you specify: 

1. Click on the yellow cell under Condition on the Decision Table
2. Click on the Source tab on the configuration pane
3. Click on the name of the field you want to set the Condition on
4. The name of that field will appear in bold text in the yellow cell under Condition 

For example, if we wanted to set Category as a condition on a Decision Table for the Account entity:

 

Category would then appear in bold text in cell A2.
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Now that we have selected Category as our Condition we need to set the values for Category that we want the Decision Table to act on.
Expand the list of values available for Category and then click on cell A4 and then click on Preferred Customer from the Category values.

 

Preferred Customer appears in cell A4 surrounded by curly brackets. 

Note: The curly brackets mean that this is an OptionSet value.

If you repeat the procedure for cell A5 and click on Standard then this will populate that cell with {Standard}:
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Setting a Condition on a related entity field
If you need to set a Condition based on a field in a related entity then you can do the following:

Add a Condition column to the Decision Table if needed
Click on the yellow cell under Condition (in row 2)
Click on the Source tab on the configuration pane 
Expand the Related (N:1) tree node and click on the field you want to select

In this example we are adding a condition to the Decision Table that looks up the Country/Region field of the Primary Contact record connected to
the Account record the Decision Table is executing on.
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Adding a Check Condition to a Field
In certain scenarios, you need to check if a field contains data, or does not contain data etc. With Decision Tables, this is easy to do. Instead of writing a
separate Calculation you add the field as a condition column as normal, then find the function you need in the functions tab. Hold down the CTRL key
and click on the function - it will be populated into the Decision Table inside {{{ }}} notation.

In the screenshot below, we are checking if the Estimated Revenue is greater than or equal to 100 and less than 200, and the Actual Revenue field
contains data.

Adding more Complex Conditions
Decision Tables allow you to include more complex Conditions than just selecting from the Source tab.

You can write formulas that can return values to be checked against. These are done in the Global Calculations tab of the Decision Table (select the tab
from the bottom of the Decision Table editor - this tab is hidden by default and can be shown by pressing F4 or right-clicking and selecting Operations
> Toggle Advanced Mode).
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An example of when you would use this functionality is if you needed to check the age of a Contact as part of the Condition.

To accomplish this you would set the Calculation Name as Age (you can call this whatever you like, but make sure it is meaningful for someone reading
the Decision Table). The calculation formula is entered as you would any standard

North52 Formula:
Click on cell B2, then click on the Functions tab and expand the Date node and click on the DateDiff() function.
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This will put the DateDiff function template into cell B2.

Click on B2 again and the formula will appear in the command editing bar.

Now delete 'fromdate' from the formula until you are left with DateDiff( , 'todate', 'interval')
Place the cursor before the the first comma and expand the Source tab looking for the Birthday field. In this example we are getting the Birthday field
of the primary Contact record on the Account.

Now repeat the procedure for the 'todate' and replace it with the function Utcdate() and finally replace 'interval' with 'y' 

This formula will return the age in years of the primary Contact on the Account record.

To add this as a Condition on the Decision Table:

Click back to the Decision Table, by clicking the Decision Table tab at the bottom of the editor
Add a new Condition column if needed, by right-clicking on the editor canvas and selecting Insert > Insert Condition
Click on the yellow cell under Condition (in row 2)
Click on the Source tab on the configuration pane 
Expand Calculations and Age should appear there (or whatever you named your calculation)
Click Age

Age should now appear in bold text for the Condition.

In this example the conditions are now: 

if age is less than 18 and the account number is less than or equal to 2000
if age is greater than 18 and the account number is greater than 2000
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Setting a Default value for a Condition
To learn more about default values - please review this article https://support.north52.com/knowledgebase/articles/473859-how-to-handle-null-or-
empty-values-with-north52

You can set a default value for any of your conditions by right-clicking on the Decision Table editor canvas and clicking on Operations >  Toggle
Advanced Mode from the contextual menu. This will display another row (row 3, which is normally hidden) under your Conditions.

By adding a dot and a 0 to the Account Number condition it means that if a null value is found in that field, the Decision Table will use a zero instead
thereby protecting your formula from breaking.
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Setting OR Conditions on an OptionSet Value
In this example we want to update the account Category field to Preferred Customer if the Payment Terms are Net 60and the Freight Terms are No
Charge or FOB.

Without using an an OR we could simply do the below.

However there is an easier way to achieve this by putting both OptionSet Values into the same field. After clicking on No Charge, immediately click
on FOB as well.

Now both OptionSet Values will appear in Address 1: Freight Terms  - meaning that No Charge or FOB and Net 60 are selected then the Category will be
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updated to Preferred Customer.

Setting OR conditions on different fields
In this example in order to be a Preferred Customer the Freight Terms can be either No Charge or FOB or the Payment Terms can be marked as Net
60.

It's very easy to change the above example to accommodate this requirement:
Click on the letter of the first column you want to add to the OR statement - this will highlight the entire column. 

Keep the left mouse button pressed and drag your mouse over to the column you want to add into the OR statement.

Note: You will have to position the columns you want to put into the OR statement next to each other.

In the below example you can now see that both column A and column B are highlighted.  Next right-click on the editor canvas and from the pop-up
menu click Set Condition Column Options > Condition-Or 
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Column A and Column B are no longer showing as Condition but as Condition-OR.

Both of these columns are now successfully OR'd together.
 

Multiple Sets of OR Conditions
It is possible to chain columns of OR conditions together.

Scenario: If the following Conditions are met:

Account Name is Microsoft OR the Annual Revenue is greater than $100,000,000 
AND 
Address 1 City is Redmond OR Address 1 State/Province is Washington 
AND 
Category set to Preferred Customer

Then sent the Credit Limit on the Account to $100,000.

To do this, you set your Conditions up together and group them as an Or Condition as demonstrated above.
Then edit the cells that contain Condition-Or and add a hyphen and a number to them, this number then groups the OR statements together.
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In this example Account Name and Annual Revenue are the first Condition-Or-1. And then Address 1 City and Address 1 State/Province are the
second Condition-Or-2.
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DT - How to - 04 - Set up your Actions
[TOC]

Overview
This article will detail everything you need to know about Actions in North52 Decision Tables.

What is an Action?
The Action is what you want the Decision Table to do when the Conditions have been met. 
It could be anything from setting a value in a field, creating a new entity, hiding a section on a form to executing a workflow.

How to set a Simple Action
To set an action:

1. Click on the green cell under Action on the Decision Table
2. Click on the Source tab and click on the name of the field you want to update

For example to set an Action that updates the Preferred Method of Contact on an Account:

Click on the green cell (row 2) under the Action heading
Click on the Source tab on the configuration pane
Click on the Preferred Method of Contact field

Preferred Method of Contact will now appear in the green cell in the Action column.
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This tells the Decision Table that if the Conditions are met then the Action to be taken will affect this field.

To make a specific update to the Preferred Method of Contact Action we click an empty cell in that column and then expand the Preferred Method of
Contact node in the Source tab of the configuration pane to select the desired result. 

In the below screenshot Email has been selected and {Email} has appeared in the Cell B4.

Action Cell Values
You can type the following values into an Action cell:

If the value is in single quotes then it is treated as a String value
If the value is in curly brackets {} and the Column has a Name then it is treated as an OptionSet value 
If the value is a number then it is treated as a Number
If the value is in curly brackets {} and the Column has no Name then it is treated as a Complex Action

More details on Complex Actions can be found further down in this article.

Default Actions
If you want an Action to be completed anytime the Decision Table is triggered then you can set an Action with no Conditions associated to it.

In the example below we want to set the default priority on all Case entities to Normal when the case is created, however:

If the Case was Received As a Public message with a Dissatisfied Satisfaction rating then the Case Priorityshould be High
If the Case was Received As a Public Message with a Very Dissatisfied  Satisfaction rating then the CasePriority should be Critical
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Note: Exit this Decision Table on First Match is unchecked (found under Hit Policy on the right-click contextual menu) to set all cases
to Normal Priority first, and then the additional conditions will be checked to determine if additional Actions should be carried out as well.

Complex Actions
Decision Table Actions can do much more than simply update fields.

At the bottom of the Decision Table you can change to the Actions Table by clicking the Actions tab:

For this example we are going to extend the above functionality by adding an additional Action to create a Task for the owner of the case record if
the Case Priority is set to Critical.

First enter the Action Name, this will be used by the Decision Table to identify the Action. Type in CreateCaseTask (you can call the action anything you
like, choose something meaningful that makes it obvious what the Action will do)

Next click on the cell next to the Action Name (B2) in the Action Value column.

As we are entering a formula click the + icon at the right of the command bar to expand the formula editor.
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Create the following formula in the formula editor.

Formula
CreateRecord('task', 
            SetAttributeLookup('owninguser', 'systemuser' ,[incident.ownerid]),
            SetAttribute('subject', 'Critical Priority Case Assigned to you!')

)

Click on the X icon to close the formula editor - this inserts the formula into the Action Value cell:

We have now finished defining the Action. Return to the Decision Table sheet and add a new Action column by right-clicking and selecting Insert
> Insert Action from the contextual menu.
Note: We don't name the column this time as we are not updating a specific field
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Click on the Source tab and expand the Actions node. The CreateCaseTask Action is now listed here.

Select cell D6 next to Priority and then click on CreateCaseTask from the Source tree to add it to the Decision Table editor.

The Decision Table will now create a Task for the Owner of the Case when it is setting the Priority of the Case to Critical.

You can set as many Complex Actions and Simple Actions against a Condition as you wish, simply add more Action columns.

Variables
Sometimes in Decision Tables you will need to Sum up a value based on the Condtions.
This sort of Sum up functionality can only be used in Decision Tables with the Exit this Decision Table on First Match feature turned off.

To perform a Sum up Calculation like this:

Name your Action
Right-click on the Decision Table and select Toggle Advanced Mode from Operations
Row 3, which is hidden by default, will appear on the Decision Table
Under your Action Name enter +=
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This will tell the Decision Table that the values in this row should be used in a Sum calculation within that Decision Table
The name of the Action column will then appear under the Decision Table Calculations node on the Source tabof the configuration pane 

In the below example we use this functionality to calculate an Auto Insurance Premium based on a variety of Conditions

We can then use that value by adding in an Action to update the Premium and referencing the value by clicking on AutoPrem from the Decision Table
Calculations node.
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DT - How to - 05 - Use Name or Value fields in Decision
Tables
[TOC]

Overview
This article will explain when you would use certain Name and Value fields within a Decision Table. There are two variations on this Name and Value
combination. 

Option Sets:      {Name} or {Value} 
Lookups:           (Name) or (Value)

When used in Conditions
Option Sets
In an Option Set the value is the Integer value that is actually stored behind the scenes e.g. 100000000 while the name is the string value that appears
on the Option Set for the end-user. The name shown to the user can be different depending on the language of the user. A user with the language
setting of 'English' will see the name in English but a user with a Spanish language setting will see the Spanish name. So we need to be very
careful when using the name field when designing business rules as normally we would want the business rule to execute the same independent of
language. 

When you are checking the value of an Option Set in a Condition, you would always use the value field as this is the actual value stored in the field.
This is also the default that North52 BPA uses when you select option set items from the left-hand Source menu. It also means that the logic will work
the same way independent of language. 

  e.g. Account entity 'Industry' field

'industrycode'                       Stores the integer   {Value}
'industrycodename'              Stores the string     {Name}

Lookups
With a Lookup field the value is the Guid of the record being looked up while the name is the name of that record.

When you are checking against the value of a Guid you would use the value field, however you could use the name field if you want to do a string
comparison. The string comparison is useful because one of the issues with CRM is that Guids change between CRM systems (e.g.
Dev/Test/Production) for lookups so using the name keeps everything consistent. 

 e.g.  Account entity 'Primary Contact ID' field

'primarycontactid'                 Stores the guid    (Value)
'primarycontactidname'        Stores the string  (Name)
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When used in Actions
With Actions, the value field should always be used when bringing a field into row 2 of a Decision Table.

This would apply to any Action including setting a value into the field or applying a ClientSide function like hiding, disabling or showing the field.

Rule of Thumb
Value should be used in almost all cases unless you are attempting a string compare (e.g. checking if the name of a Contact lookup = 'Patrick
McInerney' ) in a Condition.
 

Performance
The Name and Value fields when used correctly can really speed up performance on a CRM system as they can save you performing additional API
queries to the CRM system for metadata in the case of option sets and entity queries in the case of lookups.
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DT - How to - 06 - Use the Decision Table Context
(Popup) Menu
[TOC]

Overview

This article will detail all the options available in Context or Pop-up menu for a Decision Table.

How to Access the Menu
If you right click within a Decision Table then the menu will appear:

  

Insert
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Insert Row
A decision table comes with 35 rows by default, if you need any additional rows you can add them using this command. Just highlight as many
additional rows as you want and then click on the Insert Row. If 10 rows are highlighted then 10 rows will be added.

Insert Condition
Adds an additional Conditions column.

Insert Action
Adds an additional Action column.

Insert Decision Table
Add an additional Decision Tables sheet to your Decision Table - making it a Multi-Sheet Decision Table.

Insert Duplicate Decision Table
Creates a copy of the current Decision Table sheet.

Insert ForEachRecord
Adds a ForEachRecord column into the Decision Table.

Insert DoLoop
Adds a DoLoop column into the Decision Table.

Insert Inline Calculation (==)
Adds a calculation column, whose final value is output as a variable that can be used in subsequent parts of a Decision Table formula. 

Insert Table Calculation (===)
Used only when there is a ForEachRecord or DoLoop column in the Decision Table. Adds a calculation column that is calculated outside of the loop and
whose final value is output as a variable that can be used in subsequent parts of a Decision Table formula.

Insert Increment Calculation (+=)
Adds a calculation column, which will increment in value for each row that matches the conditions and whose final value is output as a variable that
can be used in subsequent parts of a Decision Table formula. Will only work when the sheet Hit Policy has the Exit this Decision Table on First Match
unchecked.

Insert Decrement Calculation (-=)
Adds a calculation column, which will decrement in value for each row that matches the conditions and whose final value is output as a variable that
can be used in subsequent parts of a Decision Table formula. Will only work when the sheet Hit Policy has the Exit this Decision Table on First Match
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unchecked.

Delete

Delete Row
Deletes the selected row of data.

Delete Column
Deletes the selected column.

Delete Sheet
Deletes the Decision Sheet you are working on.
 

Cells

Cut, Copy & Paste
These work exactly like the standard Windows Excel style Cut, Copy and Paste functionality.
 

Set Condition Column Options
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Condition
Reverts back or change columns into a standalone condition.

Condition A and Condition B

Condition-Or
Combines Conditions Columns together into an OR condition.

Condition A OR Condition B

Condition-Compound-Or
Encloses two or more columns together in brackets. These Columns are then separated by AND conditions.

(Condition A and Condition B)

Condition-Or-Compound-Or
Enlcose two or more columns together in brackets. These Columns are then separated by OR conditions.

(Condition A OR Condition B) 

Please review this article for more information on how to configure OR Conditions.  
 

Set Action Column Options
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Set ClientSide Action
Allows you to carry out ClientSide actions, only relevant for when Mode is set to Clientside.

Set ServerSide Acton
Allows you to carry out ServerSide actions, only relevant for when Mode is set to Clientside.
 

Set Sheet Options

 

Use CreateRecord
Change the sheet behavior to allow for Creation of records.

Use UpdateRecord
Change the sheet behavior to allow for Updating of records (this is the default setting).

Use TargetEntity
Change the sheet behavior to allow for updating of data before it is committed to the database.

Use ClientSide
Change the sheet behavior to use the SetClientSideField() function rather than the default UpdateRecord() function. Use ClientSide will be selected by
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default for formulas with a Type of ClientSide Perform Action.

Use Action
Change the sheet behavior to use the SetActionOutput() function for any field references.
 

Hit Policy

Exit this Decision Table on First Match
This command tells the Decision Table to stop checking conditions once it finds it first success.

By default this is turned on - however you may not always want this feature turned on.

For example if you have several independent updates executing at the same time. Instead of creating several different formulas you could instead
create a single decision table and put all the logic into it.

As long as the Exit on First Match is turned off the Decision Table will execute the actions for all conditions that are fulfilled.

Exit All Decision Tables on First Match
This command is used in Multi-Sheet Decision Tables. If it is turned OFF then when the Decision Table has finished processing the current Decision
Sheet, it will move to the next Decision Sheet in the Decision Table.

However if it is turned ON - then the Formula will fully exit on this Decision Sheet and not execute any additional Decision Sheets afterwards.
 

Operations
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Toggle Advanced Mode
This command shows/hides values stored in row 3. You will see the full names of any fields being used in the Decision Table and be able to set default
values for them. Please click here for more information on setting default values. It also shows/hides the Global Calculations and Global Actions sheet
tabs.

Toggle Exclude Columns
If you would like to exclude a column from executing you can click into the column and select this option. Select it again to include the column again.
This option is useful when you temporarily need to exclude logic for testing purposes. 
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DT - How to - 07 - Advanced OR Conditions in Decision
Tables
[TOC]

Overview
This article will detail how to set up Complex OR Conditions in North52 Decision Tables.  

OR Conditions allow you to keep your Business Logic on the same line instead of creating multiple rows producing the same result.

Basic Condition
When you add a condition to your Decision Table it is by default an AND type Condition. 
This means that it must be true for your row to execute its action.

In the below example: the Student Level must be Undergraduate AND the result of DistanceCalc must be less than 6for the row to be evaluated as true
and execute its action.

Basic OR Condition
OR conditions must be set side by side in a Decision Table. To use OR conditions you highlight the columns you want to set together as OR
conditions and right click on the Decision Table. This will bring up the Context Menu. From this you can click on Toggle Column OR to set the columns
as OR Conditions. You can see step by step instructions here.

Below is an example of a basic OR Condition.

Here the Student Level must be Undergraduate AND the result of DistanceCalc must be less than 6 and they must be a Senior Student 

OR 

the Student Level must be Undergraduate AND the result of DistanceCalc must be less than 6 and they must be Living in their Parents Home.

This could also be represented in the Decision Table as the below:
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Compound OR Conditions
Compound OR conditions are used for more complex logic. For example where the OR Condition contains internal AND conditions. 

To change columns to Compound OR's, highlight the columns and right click to bring up the context menu. Click Toggle Column OR and the columns
will change to Condition-OR. Bring up the Context Menu again and click Toggle Column OR again and the columns will become Condition-Compound-
OR columns.

To group Condition-Compound-OR columns together; edit the Row 1 cells and add numbers to them manually. In the below example Columns
A and B are part of the same Condition-Compound-OR statement because their Row 1 cell's are Condition-Compound-OR-1.

Below is an example of a Condition-Compound-OR. Here you must be a Senior Student AND living at home, OR a postgraduate AND living within 6
miles.

This could also be written in a Decision Table as:
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DT - How to - 08 - Use ClientSide Decision Tables -
General Information
[TOC]

Overview
As of release version 510, North52 Decision Tables support multiple ClientSide actions directly from the Action columns on your Decision Table.

With this functionality you can set ClientSide functions against specific fields, make changes to the form and even execute ServerSide functionality
concurrently.

Formula Type
If you want to use a ClientSide Decision Table then you must set the formula type to ClientSide - Perform Action . 
Note : Its useful to check your Decision Sheet is set to by right clicking and selecting Set Sheet Options

Note: With all ClientSide formulas you must click on N52 Commands -> Publish Formula after saving to publish the formula to the relevant entity
forms.

Source Settings
As with North52 Classic client side Formulas you can register the Decision Table against the various forms on your entity executing
as OnLoad OnSave etc. as well as OnChange of various fields. In the example below you can see the Decision Table triggers have been set
for OnLoad of the main Account Form (*** Account Events ***) and will also fire when the website field is changed.
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ClientSide Example/Exercise - Fields
In this simple example we will hide the Fax field on the main account form if the Phone does not contain data:

Click on Cell A2 (1) in the Decision Table and then click the Source Tab (2) in the configuration pane. In the search field type phone and press enter (3).
Then click on Main Phone from under the Source node (4):
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Next click on Cell B3 and add Fax here using the same steps as above. When you are finished your Decision Table should look like the following:

Click on Cell A4 and select the Functions Tab. Enter 'doesnot' into the search field and press enter. Hold down the CTRL key and click on the function
name. {{{DoesNotContainData}}} will be inserted in Cell A3. Click on Cell B4 and control-click on the HideField function, {{{HideFields}}} will be inserted
in Cell B4. 

When the field Main Phone does not contain data then the Fax field will be hidden.

ClientSide Example/Exercise - Form Actions
We are going to extend the above example slightly to add a form notification that the Fax field has been hidden.
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Add another Action column to the Decision Table

Click in cell C4, select the Functions tab, enter SetFor in the search field and press enter:

Shift-click the SetFormNotification function to open the function wizard
Leave the Friendly Name field blank as we are going to insert the function directly into the cell for this example. If we wanted to show a more
friendly name and move the function logic to the Global Actions sheet we would enter a name here and select Action from the Type drop down
In the Message field type The Fax field has been hidden!
Select INFO for the Level
Enter msg1 in the UniqueID field
Click Generate

Click Save

Test the formula and you should see that when the Main Phone field does not contain data a message will be displayed on the form and the Fax field
will be hidden. You can add as many ClientSide functions together like this as you wish.

Server Side Functionality
It is possible to create ServerSide actions that will execute along side the ClientSide functionality. You can see an example of this here: 
xRM-Formula #164 Audit log of Users who access Invoices
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DT - How to - 09 - Use ClientSide Decision Tables -
Overview
[TOC]

Overview
Multi-Sheet Decision Tables allow you to take complex business requirements and break them down into constituent sets of business rules. It does
this by allowing you to have multiple decision sheets with the formula. This can useful for both making your Decision Table logic more readable as well
as separation of different entitlement criteria.

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Setting up a Multi-Sheet Decision Table
To create a Multi-Sheet Decision Table you click on Commands and then on Toggle Editor as you would for a standard Decision Table.

This will open up the standard Decision Table canvas.
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As you can see from the above screenshot you now have 3 sheets on the Decision Table.

Decision Table
Calculations
Actions

Right-click on the Decision Table and the Context-Menu will popup, from this select Insert > Insert Decision Table

This will add a second Decision Sheet.
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This is now a Multiple-Sheet Decision Table.

Renaming Sheets
To rename a Decision Sheet double click on the sheet name.

The text will become editable and you can enter the new name for the sheet.

Once the sheet is renamed just click off the field and the sheet name will be changed to the new value. 
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Decision Table Calculations
Each Sheet in the Multi-Sheet Decision Table can generate results and these may need to be accessed from other Sheets.
These will show up under the Decision Table Calculations node on the Source tab of the configuration pane.

These are separate and distinct from regular Calculations.

How to set up Decision Table Calculations

Name your Action something meaningful
Right-click on the Decision Table and select  Operations > Toggle Advanced Mode
Row 3 will appear on the Decision Table Sheet
In the cell below the Action Name type in "=="
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This will mark this Action as a Decision Table Calculation
This Action Name will now appear in the Decision Table Calculations node of the Source tab

In the example below we are marking Discount % as a Decision Table Calculation

This Decision Table Calculation is now available to be used in other Decision Table Sheets.

Copying Entire Decision Table Sheets
It is possible to copy an entire Decision Table Sheet within the same Multi-Sheet Decision Table.

To do this:

Right-Click on the Decision Table Sheet to bring up the context-menu
Hold down the CTRL key on your keyboard and click on  Cells > Copy from the context-menu
The entire Decision Table Sheet will be duplicated 
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DT - How to - 10 - Introduction to Multi-Sheet Decision
Tables
[TOC]

Overview
Multi-Sheet Decision Tables allow you to take complex business requirements and break them down into constituent sets of business rules. It does
this by allowing you to have multiple decision sheets with the formula. This can useful for both making your Decision Table logic more readable as well
as separation of different entitlement criteria.

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Setting up a Multi-Sheet Decision Table
If you are in the Classic editor mode click on Commands and then on Toggle Editor to change to the Decision Table editor.

 

Right-click on the Decision Table and the Context-Menu will show, from this select Insert > Insert Decision Table
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This will add a second Decision Sheet:

This is now a Multiple-Sheet Decision Table.

Renaming Sheets
To rename a Decision Sheet double click on the sheet name.

The text will become editable and you can enter the new name for the sheet.

DT - How to - 10 - Introduction to Multi-Sheet Decision Tables - Page 49 of 98

https://www.north52.com/knowledgebase/multisheet_insert_decision_table.png
https://www.north52.com/knowledgebase/multisheet_new_decision_sheet.png
https://www.north52.com/knowledgebase/multisheet_rename_decision_sheet1.png


Once the sheet is renamed just click off the field and the sheet name will be changed to the new value. 

Decision Table Calculations
Each Sheet in the Multi-Sheet Decision Table can generate results and these may need to be accessed from other Sheets.
These will show up under the Decision Table Calculations node on the Source tab of the configuration pane.

These are separate and distinct from Global Calculations.
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How to set up Decision Table Calculations

Right-click on the Decision Table and select  Insert > Insert Inline Calculation (==)
Replace the Set Name placeholder text with something relevant to your needs 
This Calculation Name will now appear in the Decision Table Calculations node of the Source tab

In the example below we are marking Discount % as a Decision Table Calculation
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This Decision Table Calculation is now available to be used in other Decision Table Sheets.

Copying Entire Decision Table Sheets
It is possible to copy an entire Decision Table Sheet within the same Multi-Sheet Decision Table.

To do this:

Right-click on the Decision Table and select  Insert > Insert Duplicate Decision Table
The entire Decision Table Sheet will be duplicated 
Rename the copied sheet to something meaningful to your needs
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DT - How to - 11 - Use Find and Replace in a Decision
Table
[TOC]

Overview
The Find and Replace functionality can quickly and accurately find all (and potentially change) references to fields, functions and strings. It works well
in conjunction with N52 Commands > Clone Formula when you have a similar formula to replicate. 

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Find 
You can quickly search all Decision Sheets for any text, function or reference inside all Decision Table sheets. 

You can search row by row:
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or column by column 
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Replace 
Anything you find can be also replaced. This allows for quick renaming or adjustments to your Decision Table. 

Replace values one cell at a time:
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Or all at once:
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DT - How to - 12 - Use Global Fetch XML Sheet
[TOC]

Overview
The Global FetchXml sheet is displayed when using the Decision Tables Advanced Mode. It allows the user to quickly add and edit Fetch XML queries to
be referenced by specific functions (e.g. FindValueFD) with the Decision Table sheets. 

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Where to find Global FetchXml 
To show the Global FetchXml sheet, open a Decision Table, right-click and select Operations > Toggle Advanced Mode

You will then see the Global FetchXml sheet (along with other Advance Mode sheets like Global Calculation) 
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How to setup Global Fetch XML
In a cell in column A, give the Fetch XML a name
Then expand the advanced editor for the corresponding cell in column B
Enter the Fetch XML - this example is a query to pull back all active cases (if required you can parameterize the Fetch XML query using {0}, {1}...
{n} placeholders)
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Collapse the Advanced Editor and click Save
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Go to the Source tab and select the refresh icon
Go to the Fetch XML tab, you will see your new Fetch XML
Now you will be able to reference this Fetch XML

Example
Below is an example showing how you can reference the Fetch XML you specify on the Global Fetch XML sheet. The scenario shows how we can loop
over the records returned by the Fetch XML query and update the records using a Decision Table).
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DT - How to - 13 - Global Actions sheet
[TOC]

Overview
The Global Actions sheet is displayed when using the Decision Tables Advanced Mode. It allows the user to quickly add and edit Actions that can be
referenced by Decision Table sheets.

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Difference between a Global Action and a Global Calculation 
A Global Action will only be executed when referenced elsewhere in the Decision Table.

A Global Calculation sheet will be executed at the start of the formula regardless of whether or not it is referenced. 

Where to find Global Actions
To show the Global Actions sheet, open a Decision Table, right-click and select Operations > Toggle Advanced Mode

You will then see the Global Actions sheet (along with other sheets like Global Calculations and Global FetchXml) 
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How to setup Global Actions
In a cell in column A, give your Action a name.
Then expand the Advanced Editor for the corresponding cell in column B
Enter your Action like below (in our example we wish to execute a workflow called Send SMS for an Account):
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Collapse the Advanced Editor and click Save
Go to the Source tab and select the refresh icon
Expand Global Actions, you will see your Action
Simply click on this node to add a reference to this Action within a Decision Table:
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How to setup Global Action using a wizard
When you are using the function wizard in a Decision Table, you can give that function a friendly name and choose whether this reference is stored as
a Global Action or a Global Calculation. 

After selecting Generate, this function will be automatically added to the Global Actions or Global Calculations sheet depending on the Type selected: 
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DT - How to - 14 - Global Calculation sheet
[TOC]

Overview
The Global Calculation sheet is displayed when using the Decision Tables Advanced Mode. It allows the user to quickly add and edit Calculations that
can be referenced by Decision Table sheets.

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Difference between a Global Action and a Global Calculation 
A Global Action will only be executed when referenced elsewhere in the Decision Table.

A Global Calculation sheet will be executed at the start of the formula regardless of whether or not it is referenced. 

Where to find Global Calculations
To show the Global Calculations sheet, open a Decision Table, right-click and select Operations > Toggle Advanced Mode

You will then see the Global Calculations sheet (along with other sheets like Global Actions and Global FetchXml) 
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How to setup Global Calculations
In a cell in column A, give your Calculation a name.
Then expand the Advanced Editor for the corresponding cell in column B
Enter in your Calculation like below (in our example we are determining the date for someone's next birthday based on the current date)

Collapse the Advanced Editor and click Save
Add any other Calculations you may need
Go to the Source tab and select the refresh icon
Expand Global Calculation, you will see your new Calculation
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Now you will be able to reference this Calculation in any sheet

How to setup Global Calculation using a wizard
When you are using the function wizard in a Decision Table, you can give that function a friendly name and choose whether this reference is stored as
a Global Action or a Global Calculation. 

After selecting Generate, this function will be automatically added to the Global Actions or Global Calculations sheet depending on the Type selected.
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DT - How to - 15 - Source tab
[TOC]

Overview
The Source tab allows users to reference fields (attributes) on a record and fields on records related to the primary record. 

It also allows users to reference environmental values such as Processes, xCache records, Global Calculations, Global Actions and Decision Table
Calculations.

The Source tab can be used in conjunction with Classic or Decision Tables, in this article we will focus on its use in Decision Tables. 

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

The following parts of the Source tab are explained below:

Source
Related (N:1)
Related (N:N)
Forms
Processes
xCache
Global Calculations
Global Actions
Decision Table Calculations

Source 
The Source tree shows all the fields on an record. Clicking a field will place a reference to the field in the selected cell of the Decision Table:
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Right-click and select Operations > Toggle Advanced Mode to reveal Row 3 as shown below:
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If the field's logical name is needed instead, Ctrl-click the field name in the tree to place the field's logical name into the cell:
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Option Set Field: Name and Value
Option Set fields can have different iterations depending on their type: Value and Name 

The Value iteration references the value stored in the database (e.g. a number for an option set item, a GUID for a lookup). It is the iteration used
when updating an record or when interacting with the system
The Name iteration references the user friendly equivalent of value displayed to the end user

Example:
A Contact record with the Bill To option selected for the option set field Address 1: Address Type:
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Selecting Address 1: Address Type {Name}  will reference the string Bill To 
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However selecting Address 1: Address Type {Value}  will reference the Bill To's value which is 1
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Note: Most times you will want to reference the Option set Value - it is this value that needs to be updated/referenced when interacting with records. 

Lookup Field: Name, Value or Type
Lookup fields can have different iterations depending on their type: Value, Name and Type

The Value iteration references the value stored in the database (e.g. a number for an option set item, a GUID for a lookup). It is the iteration used
when updating an record or when interacting with the system
The Name iteration references the user friendly equivalent of value displayed to the end user
The Type iteration references the entity type, e.g. contact, account, lead, etc

Example:
The Primary Contact field on the Account entity:
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Selecting Primary Contact {Name} will reference Cathan Cooke
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Selecting Primary Contact {Value} will reference the GUID of the Contact Cathan Cooke:
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Selecting the Primary Contact {Type} will reference the entity type of the contact being referred to - in this case it will return contact:
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Note: Most times you will want to reference the lookup Value - it is this value that needs to be updated/referenced when interacting with records. 

Related (N:1)
The Related (N:1) tree shows the N:1 related entities of the record. From this tree a you can access the related entities fields via the Attributes branch: 
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You can also access the related entities' related entities. In the screenshot below, the grandparent Account's name is referenced: 
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This can continue as far down the relationship hierarchy as you need to go.

Related (N:N)
The Related (N:N) tree provides access to the name of the N:N relationships:
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Forms
The Forms tree provides access to the logical names of the source entity's forms and their Section/Tabs/Fields:
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Processes
The Process tree provides access to the names of the active Processes in the instance:
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xCache
The xCache tree provides access to the active xCache records that are stored in the instance: 
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For more information on xCache records, please see the xCache training course.

Global Calculations
The Global Calculation node provides access to the Global Calculations that have been created and stored in the Global Calculation sheet for
this Decision Table Formula. 
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Referencing the Global Calculation in a Decision Table sheet:

Note: To create or edit a Global Calculation, right-click and select Operations > Toggle Advanced Mode and the Global Calculation sheet will be shown
(you can also press F4).

For more information on Global Calculations, please review the Global Calculations 'how to' knowledge base article.

Global Actions
The Global Actions node provides access to the Global Actions that have been created and stored in the Global Actions sheet for this Decision Table
Formula.
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Referencing the Global Action in a Decision Table sheet:

Note: To create or edit Global Actions, right-click and select Operations > Toggle Advanced Mode, and the Global Actions sheet will be shown (you can
also press F4).

For more information on Global Actions, please review the Global Actions 'how to' knowledge base article.

Decision Table Calculations
The Decision Table Calculation node provides access to the calculations that have been created inline on a Decision Table sheet (Inline Calculation,
Table Calculation, Increment Calculation, Decrement Calculation or SetVarConcat Calculation):
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Also, whenever an Inline Calculation, Table Calculation, Increment Calculation, Decrement Calculation or SetVarConcat Calculation is set, it will appear
here for referencing 
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DT - How to - 16 - Use the Validator
[TOC]

Overview
The Validator allows you to run a basic and an advanced syntax check on your Formula. It will scan and highlight errors in the Formula structure. 

This can be used in conjunction with Classic or Decision Tables - in this article we will focus on its use in Decision Tables. 

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

Validator
You can locate the Validator on the top right of the editor command bar as shown below:

For the Validator to work, changes must be saved before selecting it:

This includes the Advanced Editor as well - it must be collapsed and saved before a syntax check can be performed:
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An example of an Error shown by the Validator:

We can see the error highlighted by toggling the editor to classic mode:
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DT - How to - 17 - Tester (execute Formula from the
editor)
[TOC]

Overview
The Tester allows users to quickly execute and test a Formula from within the Formula editor. 

This can be used in conjunction with Classic Formulas or Decision Tables, however, in this article we focus on its use in Decision Tables. 

For this article it is assumed that you have at least basic familiarity with Decision Tables and/or have read the following articles:

Everything you need to know about Decision Table Conditions
How to set up your Actions!

Note: We will not detail step-by-step instructions here on how to set up Conditions or Actions, please read the above articles if you need detailed
configuration steps.

How to use the Tester
You can locate the Tester in the top right corner of the editor as shown below:

Note that the Formula must be saved before the Tester can be executed.
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The Tester will request any references to data it needs and execute the Formula using the values supplied: (Note: some formulas require the unique
ID of the record. You can typically find this in the URL of the record or by using a browser extension)

A successful execution will return result message, in this case NoOp (which means No Operation):
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If there is an error in the formula, a trace log will show up like in the image below.  For this example an IF statement without any parameters was
entered to purposefully break it:
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